FANDOM


Warning: Heavy Armory just released an update recently, DO NOT update to this new version until compatibility is addressed and a possible release of updated set of patches. It sounds like this update works off the CCOR compatible version rather than the original, so it should be fine, but several people have expressed issues with the armory this week, and upgrading HA is probably to blame. Please wait for an update to the patches.

Community content is available under CC-BY-SA unless otherwise noted.